R1
en
conf t
host R1
!
crypto isakmp policy 10
hash md5
authentication pre-share
group 1
encryption 3des
lifetime 3600
!
crypto isakmp key cisco address 10.1.12.2
!
crypto ipsec transform-set TEST esp-des ah-md5-hmac
!
crypto map R1_R2 10 ipsec-isakmp
set peer 10.1.12.2
set transform-set TEST
match address 100
!
interface lo 1
ip address 10.10.10.1 255.255.255.0
exit
!
interface s1/0
ip address 10.1.12.1 255.255.255.0
crypto map R1_R2
no sh
exit
!
ip route 20.20.20.0 255.255.255.0 s1/0
!
access-list 100 permit ip 10.10.10.0 0.0.0.255 20.20.20.0 0.0.0.255
!
------------------------------------------------------------------------------------------------------------
R2
en
conf t
host R2
!
crypto isakmp policy 10
hash md5
authentication pre-share
group 1
encryption 3des
lifetime 3600
crypto isakmp key cisco address 10.1.12.1
!
crypto ipsec transform-set TEST esp-des ah-md5-hmac
!
crypto map R1_R2 10 ipsec-isakmp
set peer 10.1.12.1
set transform-set TEST
match address 100
!
interface lo 1
ip address 20.20.20.1 255.255.255.0
exit
!
interface s1/0
ip address 10.1.12.2 255.255.255.0
crypto map R1_R2
no shut
exit
!
ip route 10.10.10.0 255.255.255.0 s1/0
!
access-list 100 permit ip 20.20.20.0 0.0.0.255 10.10.10.0 0.0.0.255
!